USB connection between ipad and macbook pro no longer working


I’m having the same issues my astropad won’t connect manually or through USB


Hi! I’m having the same issues as the folks above. I have tried everything listed above. The last thing I tried was the factory reset on the Mac app. I can make the connection over wi-fi so I’m guessing maybe I just need a new USB cord? I’m currently using the APPLE cord that came with the iPad and I have a 2017 iPad Pro 12.9. Has there been any developments lately? Are our old USB cords the problem basically?


@JimiJam Normally they shouldn’t be a problem, unless there is something faulty or broken with the cord itself.

A factory reset would have re-enabled USB connection if it was ever turned off in Astropad itself.
Just in case, you can check by going to the Debug menu-

  1. Launch the Astropad Mac app
  2. Go to Astropad’s top menu bar, hold down the option/alt key and at the same time click “Preference”
  3. This will enable the Debug tab, click it.
  4. Then check the “USB Cable” is turned on.

Make sure there isn’t anything in your ports preventing full connection.

And if you’re having no problem with wifi connection, only USB,
it’s worth trying another cord to compare if possible.

Let us know if the problem persists