USB connection between ipad and macbook pro no longer working


After doing recent astropad App updates on both my ipad 2.0 and my macbook pro, the usb cable connection is no longer working. Wifi is not an option, usb is the only reason I purchased this software, without the usb connectivity functionality, this app provides nothing for me. How to fix the issue?


Try restarting your iPad only. See if connection is re-established with USB after this.
If not, please try one more time to restart both your Mac and iPad.

Please contact us at: support [at] if this issue still persists.


having the same problem, followed the advice still won’t connect.

The Wacom has finally given out, and my iPad Pro with Astropad is my tablet, now.
USB connectivity would be nice, but I can still execute work if not.


You can try resetting the SMC of your Mac, that worked for me when I had the issue…

“Connect the power adapter to the Mac. On the MacBook / Pro’s keyboard, hold down the Shift+Control+Option keys and the Power button at the same time. Release all keys and the power button at the same time – the little light on the MagSafe adapter may change colors briefly to indicate the SMC has reset”


Thank you! Will try it.


It was a no go. I have an iMac, cleared the SMC, connected, shut down iPad Pro, etc… all the advice.
I’ll just accept this option isn’t available.


Is there anything that occurs when you try connecting with USB?
Any error messages? Can you send us a picture or screenshots of what’s on your iMac screen as well as iPad screen?


The opening screen of Astropad on the Mac and the Ipad, with Laika’s little antennae animated, same as one sees when first opening the app, and/or desktop… I’ve turned off wifi, thinking it would kick in, but it doesn’t.

A screenshot would be redundant, as we"ve all seen this, but thank you for the offer.
I’ve turned off and on IPad, computer, cleared SMC, Turned off wifi on both desktop app and computer, unplugged, re-plugged both ends of the cable
It’s the same cable that came with the iPad.


Try removing and reinstalling both apps.

Check “Astropad” in Spotlight to see if you have any other versions of Astropad save on your computer.
If you find any, remove them all. After remove the Mac app, download it again from our site again:

Then re-install the app from your iPad, (press and hold on the icon until it wobbles and tap on the (x) to uninstall it) and visit the App Store again from the iPad, and install Astropad again.

Please let us know if the issue still persists after trying this


Thank you for the reply.
I deleted and re-downloaded everything, including deleting the preferences in the library, did the same things I did as above, (cleared SMC, unplugged, etc…) and still there’s no connection.
I tried other power cords just in case.
It sounds silly, but I ran the same gamut with my regular iPad, just to be sure.
There is still no connection.
I went into the prefs of iTunes, to deactivate the syncing function, same with Photos, thinking there might be conflict of interest, and unplugged all of my hard drives. The Wacom is no longer connected to the computer, it’s now just a stand for the iPad Pro.

The computer recognizes the iPad/iPad Pro when hooked up, as I had to disengage the other apps to clear the way to make a connection for Astropad, but it seems Astropad can’t seem to recognize the hookup.


Hi Smokie,
can you locate the following file:


and can you send us this log file to support(at)

it could help us diagnose the issue.

thank you,


Thank you. just sent it.


Yes! Thank you- it works!
the setup screen cam up on both iPad and desktop-
Thanks, this will increase my ability to work longer.


Hi experiencing this issue right now, just wondering how you ended up resolving this issue?
Thanks :slight_smile:


Having the exact same issue at the moment !! My iPad constantly loses conection with my Mac making it impossible to get any work done, I bought a new connection wire thinking it might have something to do with that but it’s been no help ! How did you fix this issue ?


@Joshua_Hogan Please try a factory reset for Astropad—

Close Astropad’s Mac app.
Then hold option/alt key, while opening the Mac app again.
It will ask if you want a factory reset.

Let us know if there is any change.


I am having the same issues. Tried holding option, reinstalling, etc. Tried on my MacBook Pro and on my iMac. Used multiple different apple cables. Still does not recognize USB connection. Works fine over wifi but I do not always have that option.


@Bernie_Fritts Are all the cables tested Apple official cables?
We’ve experienced some issues in the past, where third party brands don’t always keep connection.

Please check to see if USB connection is enabled in Astropad.
How to do this:

Launch only the Astropad Mac app
Go to Astropad’s top menu bar, hold down the option/alt key and at the same time click “Preference”
This will enable the Debug tab, click it.

Check the USB connection has the check mark, if not it disables connection.

If this is enabled please let us know.


Sorry I meant to post here but forgot. It was actually a bad iPad. Apple replaced it and it works like a charm. Thanks.


@Bernie_Fritts Thanks for letting us know :slight_smile: Glad things are working now.