Undo/Redo Gesture doesn't work


Undo/Redo Gesture doesn’t work in Astropad Studio. I see the notification popping up on top of the screen that shows “Undo”, but nothing happens. Undo/Redo works when pressing the shortcuts in the shortcut bar. The other gestures that need the pencil in combination all work.


What programs are you using with Astropad Studio?


Photoshop CC on Mac OS X 10.11.6


Same here with Photoshop CC 17 but I restarted the desktop app and it seemed to work again.


@jarek_lensa Thanks for the suggestion. Definitely helpful!

@marek Maybe try restarting both apps. If that still doesn’t work, try re-entering the shortcuts to the tap gestures.

To change these go to the bottom of the shortcuts sidebar, and tap “Edit Shortcuts”. Go to the bottom, and there you can edit the Tap gestures. More info here: http://blog.astropad.com/workspace-sidebar/


I turned my ipad back on and off, restarting Astropad Studio on iPad and Mac. Didn’t help.

I re-entered the shortcuts the way you said. Now Redo works, but undo doesn’t. I have put it to Command + Z. It works on my keyboard when I do it. It also works on the virtual keyboard on Astropad. But the Two Finger gestures doesn’t.


I’m not getting custom shortcuts to work at all. Nothing seems to fix it MacOS, photoshop 6.


My tap shortcuts broke when I tried to reprogram them. Resetting to default restored the stock undo and redo commands to working.


@Infocusinc Are you using Sierra? Photoshop CS6?
What happens when you try inputting commands?


@marek What happens if you tap “Reset to defaults”? (at the very bottom of the edit shortcuts sidebar)


this didn’t help


@marek Are you using an international keyboard? If so, what type?
Also, what language version of Photoshop is used for your Mac?

For Photoshop, are Undo and Redo set to default commands or customized keys?

Photoshop bug/issue: Double-tap (UNDO) turns on Zoom?

I am using the standard English Layout on my iPad and Mac (US keyboard layout). Mac is set to English as well as Photoshop.

Now that you mention the default keys in Photoshop, this was the problem. I actually had no shortcut assigned to “Undo/Redo” in PS. I use the “Step Backward” and “Step Forward” functions instead because they do what I want which is going back a step every time I press it. So now I just assigned a keyboard shortcut to the “real” undo function in PS and the same in Astropad Studio and it works now. Though, I will never use that gesture if it works like this then, because I want to have the “Step Backward” function when I tap with two fingers. I usually want to go back in History several strokes, not just one. Can you let us just assign any key to that gesture? It also wouldn’t make sense to have a “Undo” and “Redo” gesture in Astropad for Photoshop because it’s the very same function in PS. So you have the same function on two different gestures now.


@marek Tap gestures are shortcut customizable. Step Forward and Step Backward are the default commands for Photoshop set in Astropad Studio for the Tap gestures as Undo & Redo.

What commands are set for Undo & Redo that work now with two and three fingers Tap Gestures?


as mentioned before when I use “Undo/Redo” instead of “Step Backward” for the 2-finger gesture it works in Astropad Studio. Using “Step Backward” doesn’t work


The same problem… Undo/redo with fingers does not work((((( Ps CC and Sierra, ipad pro 2017 with ios 11…


@danka_pu If you re-enter the undo/redo commands in the sidebar, is there any change?
Are you using an international keyboard?


Same issue for me. Using Danish Mac keyboard.
PS CC 18, Mac OSX 10.13
Any help would be great :slight_smile:


For others with the same issue; here is the solution:
Shortcuts have to be entered by actually pressing the keys simultaneously. I entered them by pressing the keys one by one.
Pressing them simultaneously helped fix the issue.
Especially paying close attention to whether it says “⌘ Z” or “Z ⌘” is vital - I got the zoom tool (Z) because the shortcut was entered as “⌘ Z” (with a space between the two). It should be entered “⌘Z”.