Scrolling triggers logout


I’ve had this problem hit me 3 or 4 times now over the past couple of months. Using Astropad Studio, kept up to date from App Store, iPad 12.9 first generation, Apple Pencil. MacBook Pro late 2013, macos Sierra 10.12.6. I seems to hit when I have Adobe Dreamweaver CC running, although it may or not hit when I am using that program. I should also mention I run macos with scroll bars visible to scroll with a stylus (Wacom or Astropad&Pencil).

What happens sometimes (not all the time) when I’m scrolling using scrollbars with the Pencil, Astropad Studio seems to hang. I get the stylus trace marker. If I check my MacBook, it’s at a login screen. Somehow I have been logged out of the computer. I log back in at it tries to recover me where I was, sometimes succesfully, sometimes not (i.e. beachball, hard reset required). Even if it’s successful it takes a while to get back and of course there is a risk that some work has been lost.

Anyone else have this happen?


If possible, please take a video of this occurring and send it to support[at]
This happens only when using DW CC with Astropad, no other program?
Is this the latest DW CC version?

And, your Macbook Pro has plenty of storage space?


I will try to make a video of it. It happened again yesterday. I was scrolling in Safari. The problem always hits while using a scroll bar with the Pencil. It has happened in Safari and Path Finder.

I mention Dreamweaver since that is the program I have been working with most lately. DW has been up and running in a separate desktop space, but it is not the active program when the problem occurs. I make changes to a web page in Dw then go to Safari to test it. That’s when it happens. Or in Path Finder when I’m verifying files on the server. Again, during scrolling.

This MacBook Pro has 16gig of memory. That may be the hardware max for this model.


Some things to check and see if there is any diffference:

Go to Astropad’s top menu bar,
hold down the Option/Alt key and at the same time click “Preference”
This will enable the Debug tab, select it.

For “GPU Acceleration”, try seeing if there is any difference
with this performance when setting Metal, OpenCL or CPU.

Under “Connectivity” for Rate control try comparing the different settings,
if there is a difference between Traditional and Velocity controlled.


I have a similar problem with mine, I can’t tell if Astropad Standard is causing it or if it is my computer but so far it has only happened while Astropad was open.

So when I was working in Photoshop the screen of my MacBook Pro froze completely and when it came back I was logged out and when my applications restarted I had lost anything I hadn’t saved. It also happened when I was working in Animate CC.

Any suggestions on how to fix this issue? It’s happened in the last few days, I’m running the iOS 12 beta but I don’t see how that should affect my computer.


@themathsrobot What Mac OS version is in use? And what is the year and model of your Macbook pro?
Does it have a discreet graphics card? Or no?

Have you tried restarting the Mac in Safe Mode, and see if this still happens?

If you see a black screen on your iPad, when using Astropad while in Safe Mode, this is fine.
But see if the Mac still freezes.

How to restart in Safe Mode:
-Restart your Mac.
-Immediately after you hear the startup sound, press and hold the Shift key.
-Release the Shift key when you see the Apple logo appear on the screen.
To leave safe mode, restart your Mac without pressing any keys during startup.

Please let us know if the problem still happens or not, in Safe Mode.

More on Safe Mode:


I’m on macOS High Sierra 10.13.5 right now, it is a 15" Retina MacBook Pro from mid-2014 and is configured with a discrete graphic card (Nvidia GT 750M 2GB).

As for trying in Safe Mode, I’ll try that now but the freezing was not a common occurence that occured every single time I launched Astropad so I don’t know whether I will be able to recreate it.


I should probably also mention I’m using an Nvidia Web Driver coupled with CUDA so I will try switching back to macOS’ default driver too.