Resolution MacBook Pro 2013 Retina / iPad Pro


Hello everybody!

I have a problem with my iPad Pro using astropad. I’m using it with my late 2013 MacBook Pro with Retina display. The resolution of the mac display is 2560x1600. The maximum resolution i can seit in fullscreen mode in Astropad is 1280x960, which is the max resolution of a late 2013 NON-RETINA MacBook Pro.
Is there a way to increase the max resolution in Astropad using it on my iPad Pro and the retina MacBook Pro?

Best regards!


Please search the forum. There is a how to on the best resolution for Astropad with non-retina Macs.

In a nutshell:

Enable HiDPI

Download SwitchResX

Create two scaled screen resolutions: 2732 x 2048 and 1366 x 1024. One of your iPad and another at half res.

This will create a third 1366 x 1024 HiDPI res.

Screen resolutions list here are based on the iPad Pro used as an example. Substitute your own Screen resolutions.


Sorry, but as I said, both, the MBP and the iPad Pro have retina displays. I found the workaround already, but as you mentioned, this is for the non-retina MBP.
My is a MBP with Retina-Display!


I am having the same issue , with the vary same computer, iPad pro combo, did you ever figure this out. Is it a problem with the 13" Mbp.


I have no idea. I already asked the Support via Email, but they were not able to help me.


While it is true that newer MacBook Pro’s and iPad Pro’s have retina displays.

The MacBook Pro’s native res is widescreen (16:9 ratio) and the iPad Pro is letter box (4:3 ratio),

So if you want native res on the iPad Pro, you will need to create a custom scaled resolution that fits the iPad Pro or do what Astropad does natively and crop the screen of the Macbook pro on the iPad.

Both work and is a matter of preference. I like having native res on the iPad as I am often in another room while drawing. Having access to palettes and toolbars is a must without having to drag them in some weird way.


So what’s the workaroud? I’m having the same problem! Please, help.


No help or workaround at all till now…


If you want to use a native resolution that fits your iPad, SwitchResX allows you to do this.


Sorry goodtime, but please read the text above. The max Resoltion of the Mac Book Pro Retina is 2560x1600. The Resolution of the iPad Pro is 2732x2048. So why is the max Resolution i can set in astropad 1280x960? That’s way Below Both native resolutions…


Attached is a working example using a retina display with csrutil disabled and adding two scaled screen resolutions used further down in the 1:1 Pixel Res. thread:

You do not have to enable HiDPI via the command line. Just the SwitchResX Daemon (Menu App) is required to get the HiDPI res.


Am I the only one who thinks, that Astropad should do this on it’s own? It’s designed for Mac’s and especially for the large iPad Pro.
If you ask me, it is not normal, that the customer/User has to do all that stuff to get a crisp resolution…


I agreed with you. Astropad should make this resolution option inside the app.
It really sucks that i have to download another app to make IPP looks clearer…

Mine gear is 2012 late MBP without Retina display, it looks very blur on my IPP.
Astropad did not remind us this problem on website, if so i won’t buy this app at first place…


Any reply by one of the developers?


That’s not a good solution though, it’s complicated and SwitchResX has crashed my system a few times… :cold_sweat:


Works for me. Apple Security has made it more difficult. It’s not easy I agree, but I never had any issues with scaled res’. Another option is to get a 3:4 res monitor and use that Astropad. That is of you want a full screen UX. Also an update just game out fir SwitchResX.


Buy a 3:4 res monitor just to use Astropad tho? That’s not even useful when you’re not using it and that’s what another $100?


Just giving you options if using SwitchResX is too difficult which compared to doing it in the command line, switch res x is actually much easier.


You can also use a 3:4 display for MAME. :wink:


Well you sure are creative :smirk: but I don’t play video games haha