Please Help - Adobe Illustrator Pressure Issues!


Hi Everyone,

I’m having a lot of trouble with Illustrator. I’m currently using a MacBook Pro (2016, macOS Sierra), iPad Pro 12.9 fully updated, Illustrator CC 2017 and Astropad Studio 1.0.1, but this has been an ongoing struggle with various older versions as well.

The problem is that I need pressure sensitivity for various tools - Blob Brush, Eraser, Brush Tool, but all stylus related options are grayed out (I can only choose “fixed” - all other options are grayed out).

I have read that this issue can be resolved by installing a Wacom driver on the Mac, but this has not resolved the issue for me. I have tried the latest version, as well a collection of older version drivers - nothing seems to help. I have even gone as far as rebuilding the Mac from scratch. It worked correctly for a couple days after that, and then the options grayed out again.

Any help would be very much appreciated.

Thank You!


Which driver version is installed?
Can you take a screenshot of these options greyed out?
In Brush Library, when using the Wacom 6D Brushes do you get pressure sensitivity?


In am using Wacom Driver 6.3.20-8 (but I have tried others)

That’s odd - There does seem to be some response to pressure IF I use one of the Wacom 6D built in Brushes (but these are not the brushes I need…)

Another Interesting thing - If I open the properties for one of the Wacom 6D Brushes, then deselect stylus based input methods such as pressure, bearing, tilt, etc, and then save the settings, the stylus settings become un-selectable (Grayed Out) the next time I open the Brush settings for that brush

Here is the Screenshot from one of the standard (Not Wacom 6D) brushes…


Each time testing with a new driver, was Illustrator restarted?
When you removed the other drivers, was the uninstaller (In Tablet Utility) used?


Hi Malyse,

Each driver uninstall was done with the Tablet Utility provided by Wacom, while Illustrator was closed.

After each uninstall, the MacBook was restarted.

New driver installs were also done with Illustrator closed and a restart was done before testing Illustrator.

Are there any particular Wacom driver versions you guys have seen good results with?

Thank you very much by the way for your attempt to help. I have done some looking around online, and this really feels like an Adobe issue rather than a problem with Astropad. I’ve found references to similar issues (involving various Hardware tablets, not Astropad) over the last 4-5 years on Adobe’s site, none resolved, and with very little attention from Adobe. I was hoping you guys might have a partner relationship with them that might get you better answers than us poor end users.

Thanks so much



Hi Sean,

Thanks for the added details.

This is a difficult one; and saw the same issues on Adobe’s forums as well.
We have tested with 6.3.20-8, as well as older versions like 6.3.19-10.
They work on our end, but this seems like an ongoing Illustrator issue.

Is Illustrator CC 2017 updated to the latest? The recent release had note stability fixes.

If this is already installed, maybe try resetting Illustrator’s preferences to default -
hold Option+Command+Shift as you start Illustrator.
Current settings will be deleted.

Unfortunately, no partnerships. We have to work through what we can on our end.


Hi Malyse,

Again - Thank you so much for trying to assist with this. I wanted to let you know that I resolved the issue (at least in my case) just a few minutes ago. I’ll relate what I found in hopes that some other users may benefit.

It turns out that the issue was not with AstroPad or Adobe Illustrator (At least in my case). I use a Screen Resolution Utility called SwitchResX to set my MacBook Pro’s resolution to a 4x3 aspect ratio (In order to match my iPad when using AstroPad). SwitchResX has a number of “Helper Tools” that can be installed/uninstalled on the fly from the utility’s control panel. I found after a LOT of trial and error, that when the tools are in an ‘installed’ state, Illustrator loses the ability set settings for stylus pressure. When the Helper Tools are in an ‘uninstalled’ state, pressure capability returns. I have just confirmed this by going back and forth between states about 10 times.

The most important part is that you need to restart the Mac completely after installing or uninstalling the SwitchResX Helper Tools in order for Illustrator to understand the change.

I suspect that the SwitchResX utilities somehow interfere with the Wacom Driver’s interface with display settings (for tablet to screen mapping). As far as I can tell in all of my testing, Illustrator is the only application to have this issue.

Again - Thanks so much for you help!


Hi Sean,

Thanks for updating us on this.
These details will helps us with both other users, and our support.

Wouldn’t have even guessed SwitchRex, good to know! :slight_smile:

Glad you were able to alleviate this issue.


Please help!!! I’m having the same issue!!!
I’m on the most updated versions of everything!


@TeaLynnM Do you have SwitchRes X at all?

And have you already tried resetting Illustrator’s preferences to default?
Hold Option+Command+Shift as you start Illustrator.

In Brush Library, when using the Wacom 6D Brushes do you get pressure sensitivity?


I’ve uninstalled all the Telper Tools in SwitchRez X and rebooted Mac. After that Illustrator showed all the pressure, tilt and so on settings. Thank you for the tip, you are amazing!


No SwitchRes X on my setup

OSX Sierra 10.12.6
Ipad Pro 12.9 IOS 11.2.2
Current Astropad Version as today.
Illustrator 2018

Restarting the preferences worked for me! Thanks for the help


@SamShennan Thanks for informing us!
Glad it resolved the issue for your setup :slight_smile:

  • Go to Brush Libraries –> Wacom 6D Brushes –> 6D Art Pen Brushes
  • Double-click on any of the brushes or drag one into your Brush Palette use it.
  • Now you can double-click the new brush from your Brush Palette and adjust it as needed.