Astro HQ

Illustrator Pen Pressure Issues

I’m having trouble with adobe illustrator and pressure issues.

I used pen pressure with illustrator successfully for a year or more, but on a different computer. I got a new iMac a couple of months ago, and had noticed that the pen pressure option wasn’t working, but haven’t had a chance to deal with it until now.

I’m on a 2018 iMac, with the newest version of High Sierra, and with the newest version of Adobe Illustrator 2019, and an updated Astropad studio. I downloaded the latest version of the Wacom drivers yesterday.

The pressure option on brushes is greyed out and I can’t select it. I tried resetting the preferences in illustrator and that didn’t help.

I did try using the Wacom 6d brushes, and those do offer pressure sensitivity, but it isn’t working on blob brush, eraser, etc.

Is there anything else that I should try?

An article from Astropad mentions one other thing to try once you have updated the Wacom drivers:

After adding the Wacom drivers, brush option settings will need to be manually adjusted in Illustrator. Change “fixed” to "pressure ", and set desired variations to the stroke.

There are some additional permissions that need to be granted if you have Mac OS Mojave, but it sounds like this doesn’t apply (because you have High Sierra).

I don’t know if this will help. Hope it does!


I’m having the same issues.

iMac Pro + Mojave 10.14.3
iPad Pro

The pressure is not available to select in the brush option. I’ve followed all instructions : installing latest Wacom driver (tried a few), allowing automation in Sys Preferences, updating Astropad app for my iPad and computer… the only thing that gets it to work is to keep my very old Wacom tablet plugged to my computer. If a remove it, the pressure option disappears.

The old tablet is not even supported by Mojave, so pressure doesn’t work on it…

So I kept the antique tablet plugged in and hid it under my desk !

I had the same issue. And I found the following solution:

Go into System Preferences>Security>Privacy>Accessibility, unlock the lock and add Illustrator to the list of allowed apps.