How to stop Astropad from opening automatically on system launch?

#1

Every time I restart my Mac, Astropad opens automatically. But I don’t want it to open unless I manually click the app to start it up. How can I do this?

There is no option for this in the Astropad settings. And when I went to macOS System Preferences > Users & Groups > Login Items, I saw that Astropad does not appear on the list. How is Astropad telling the OS that it should launch when the OS launches, and how can I prevent this from happening?

0 Likes

#2

My first idea was, close astropad before switching your computer off. My mac is set on “open all currently open apps and windows again when started”. Maybe yours is too.

0 Likes

#3

Thanks for the suggestion. I verified the setting you mentioned but it did not fix the issue. However, after exploring some more, I came to understand the problem.

I had the Astropad set to automatically open every time I inserted the Luna dongle. I always leave the dongle plugged into my Mac for convenience. I did not realize that every time my Mac booted or woke from sleep, it would recognize the dongle and think that it had just been plugged in. So every time my Mac booted or woke from sleep, Astropad would behave as if I had just plugged the dongle it: launching the app every time.

Now that I understand what’s happening, I set Astropad to do nothing when the Luna dongle is plugged in. That way, I can continue to leave the dongle plugged in all the time and I won’t be bothered with the app automatically launching all the time. Now, when I want to use Astropad, I just launch the app manually. Perfect solution.

1 Like