Dead in the water

I just ran an update on my Mac to v 1.9 (2806). As soon as I turn on AstroPad on my iPad Pro it crashes the desktop software. I have tried this with and without the USB connection. I have tried restarting both devices. I have tried reinstalling the software on both devices.

I was JUST using it with no problem…and then I ran the update. Bad idea.

Same issue here. We stopped using AstroPad because it simply wasn’t responding fast enough, but now with the speed increases we wanted to revisit it after this update. Feeling pretty cheated that we paid for a year’s subscription to software that has never worked correctly and is still being heavily developed.

@kittonian Please send us an email with more details to support[at]

Malyse thanks for helping me out by email. This is really the first glitch I’ve felt. I’m getting a ton of use out of AstroPad and I’m sure this will get sorted out.

@Little10Robot Happy to help!
Thanks for your patience and detailed information with this issue.

We now have the update up with a fix –
When you have the time, try it and let us know if any problems arise.