Can't get pinch-zoom working with Astropad + GIMP


Hi -

I just switched over to Astropad after doing a trial of Astropad Studio, and was disappointed that I couldn’t get pinch-zoom working with GIMP. Pinch-zoom worked out-of-the-box with GIMP in Studio, but doesn’t work with Standard.

I found the configuration settings in Standard and attempted to set the Zoom commands to + and - (GIMP standard), but it still doesn’t work. Two-finger scrolling DOES work fine, and the pinch-zoom gesture IS recognized on the iPad, but it doesn’t translate to actual zooming in GIMP.

Has anyone else been able to get this to work in Standard?

Thanks - Slapworth


What version of GIMP are you using? As well as Mac OS?

For touch gestures compatibility with GIMP needs to be fixed for Standard.
This is something we’re working on fixing.

When you added + and - , also try 1, as a shortcut command in the sidebar
does anything happen?


Thanks for the reply. I’m using GIMP 2.8.22 with High Sierra 10.13.2. The iPad is 3rd gen.

I’ll check the sidebar idea tonight or tomorrow. Do you mean use “1” instead of a “+” or “-” for one of the shortcuts?

Thanks - Slapworth


Thanks for the added info.
Suggesting to try all three (“1”, “+”, “-” ) commands, since they relate to the screen zooming in GIMP.

It gives a better idea of what’s working and what’s not.


Hi -

I tried, 1, +, and -, and none of those worked. The Mac did not respond in any way to any of them, though the gestures were clearly recognized on the iPad. Is there anything else I can try to provide more info?

Thanks - Slapworth



If you select the Canvas space, not the toolbox area, when using all three commands is there any difference?

Are these commands working when using them from your Mac keyboard?

Any third-party plugins, utilities, or drivers installed on your Mac?

For example -
SteerMouse ver. 5
Share Mouse

These are a few known to conflict input with Astropad.


I uninstalled MagicPrefs and restarted, and the issue still occurs. FWIW, I did find that I could operate the zoom commands by mapping + and - to my stylus buttons.