Can't enable screen recording on Mac

Just reinstalled after awhile and Astropad isn’t showing up at all in the Screen Recording window.

Any ideas? running Catalina btw.

strangely, i reinstalled the iPhone app and Astropad showed up.

Thank you.

I’m getting this same error after installing Catalina. Astropad requires enabling Screen Recording but my mac doesn’t register any apps as having requested Screen Recoding permissions so there is nothing to enable.

I’ve reinstalled the Astropad app (on mac) but it didn’t help. Haven’t tried reinstalling the iPad app (why should this change the behaviour on the mac?)

@Alexei Same here… in discussion with Astropad support about it

I have the same issue. Have you had any resolution from Astropad support?

@AyeCaramber Nothing successful as yet. Worth getting in touch with them as they have had a few ideas to try.
I’ll post back here if a working solution is found

@AyeCaramber OMG I’ve got it working.
Whilst searching the phrase ‘Screen Recording Permission on macOS Catalina’ I found this link on Bartender app’s site:

I was using Path Finder &/or Alfred to open Astropad - but using Finder to open it suddenly I can see the Astropad under the Screen Recording preference.

Hope this works for you

You’re a genius. Opening Astropad from Finder enables it to appear in the Screen Recording. Thanks for your research and reply!

Please I have the same problem. I just purchased the £30 app for my ipad and can’t install the mac version as it’s not appearing in “Screen Recording”

Seems like really bad costumer service