Astro HQ

Black iPad screen after update

I updated to 3.0 last night and now my iPad just has a black screen. It’s still responsive on my laptop, it just has no screen.

I’ve tried factory reset on laptop and settings are non-retina, colorsync off on ipad. Does anyone have a solution for this? Do I need to go back to an older version? I wish I hadn’t updated tbh, I didn’t have any issues with the previous version.

My laptop is actually pretty old, 2009, but it has 8 gb of ram and like I said I’ve had no issues before this aside from occasional lag/pixelation when my laptop has too many applications open.

1 Like

Hello Chris,

I apologize for the inconvenience. Could I have you try something for me to see if it will help?

With the Astropad application open on your MacBook, go to Astropad -> (holding option) Preferences -> Debug -> change the liquid engine to V2.

Let me know if that works for you!

Edit: changed to correct name.

Hi, I just downloaded 3.0 and have the same problem now. What do you mean Luna app? How do you make the fix within Astropad app on a mac or ipad.

Thanks, also Chris

Apologies for the incorrect name. The steps should be very similar!

Astropad -> (holding option) Preferences -> Debug -> change the liquid engine to V2

1 Like

Ah. That did it. At first I didn’t understand holding the alt/option key on the keyboard while clicking preferences to reveal the debug option. Thanks for the prompt support!!!

1 Like

Yep, worked for me too, thanks!

Black screen on iPad? Try these methods.
Tried holding Home Button
Tried holding Power Button
Tried holding both buttons
Tried plugging in to “charge”


I am running AstroPad on the beta 4 of macOS Catalina. Whatever I try the screen on my iPad remains black. Are there compatibility issues?

Tom Moerel

@tmoerel I have exactly the same problem! have you found a solution for this?