Astropad does not work with catalina

I have spent the better part of the day trying to get astropad studio to work on macOS Catalina without any success. I have emailed support and received some canned response about changing security and privacy settings in macOS did that, reinstalled both apps , ipad and macOS. Removed all files pertaining to astropad on MacOS. No luck. Astropad crashes my Mac. Pencil and finger gestures don’t work. To close out the program you have to do a force quit. I have asked support to call me and they refuse. They said they don’t have the staff to do that. This is sad, I really like this app and have used it for the last four months, paying the monthly rate of $11.00 per month. It looks like Sidecar is our only option now.

Hello Mphotog,
have you tried a new install?
Did you write an email to their support?

In my case (iMac & iPadPro) it is working without any problems on Mac OS Catalina.

Yes it did, gestures and pencil do not work. Im not getting any help from astropad

Do you think you can email me at Im not getting help from astropad. I know it has something to do with settings. Perhaps we can compare settings.

did you write to the support email “”?
Which settings do you need? I could upload screenshots of some settings if that would help.

I believe my setting are correct. Do you use photoshop or sketchpad. Those apps do not recognize my gestures or my pencil.
Thanks for your help.

In my research I came across an article indicating that Adobe does not recommend updating to Catalina because they have found some compatibility issues


Michael Kolch


I use it mainly with Photoshop - if it is working in general, it will work in all apps.
Only thing i could think of are the shortcuts, which could not work properly.
I have no problems.

But i am using the latest software everywhere, and the iMac is also a new model.

Thanks for the info. My macbook is new also. That is strange. I use photoshop and lightroom, I also added sketchbook and tried that app. It also does not work. It has to be my settings , but I have checked and rechecked the privacy settings as instructed and still cant get it to work.

write directly to the support via “”, good luck.

Last night they finally responded to me with more detail. They asked for more details, ie… models, programs used ect… Hopefully we can figure it out.
Thanks for your input.

It is probably due to not many apps are 64 bit.
I ask HQ this question as if A-Pad is 32 bit it will not work with Catalina she is a right b…

Re side car with out a kick stand - this only works with pre 2016 models - even if you can install Catalina - example Mac book pro early 2015 can install Catalina but the side car fall away so no sharing screen that way.

Sidecar works perfectly. I did suspect issues with adobe, but Astropad doesn’t even work thin in MacOS or Sketchbook. I have rechecked my setting and even as far as reinstalling Catalina.

Should read
post 2016 works re sidecar.

not “this only works with pre 2016 models”

Is anybody else finding sidecar is a huge battery drain on the iPad? I can’t connect via usb (“A miscellaneous error occurred (32002)”) and over wifi I’ll get maybe 15 minutes on a 12" iPad pro.

I would be happy to use Astropad if it had better characteristics than Apples solution but at the moment I can’t use Astropad due to Screen Recording permissions bug.

I have not noticed any battery drain on my ipad using sidecar, but I haven’t really looked either. Apple just released an update to Catalina. I have emailed astropad about this screen recording issue, but have not gotten any feed back from them

Can not advise here, however the battery levels will drop as more work loads involved.
I can tell you I do not use astropad much these days since I up dated to Catalina
Not liking it all 32 bit apps gone.
Hence no photoshop to use.
Hence no use of astropad.
When I did use p shop and astro, all worked fine, no probs on battery.

How do you rate side car or is it side motor cycle to astropad ?
Pro cons in use not price or time.

Astropad won’t even launch after updating. It just bounces and immediately quits. Anyone have any ideas?

I have stopped using Astro pad. Now that Apple has side car on MacBook Pro there’s no reason to use Astro pad. Once Apple update to Catalina I have had problems with Astro pad.