Astropad 1.8 unresponsive to touch


I’m using AP Studio 1.8 with Apple MBP and 12.9" iPad pro gen 2 (with apple pencil). Wired connection. All OSs and apps updated to most recent. I use Clip Studio almost exclusively for drawing. Since the 1.8 update, I’m finding multitouch gestures unresponsive and buggy. Not entirely unresponsive, but off and on in no predictable way. Pencil gestures and drawing work fine but navigation with multitouch, including pan/zoom, rotate, etc. I’m having no issues with either machine using any other app/program, so I do not believe it to be a hardware issue. I’ve restarted the iPad a few times and that seems to fix it temporarily, but it comes back. Any help would be appreciated.


Have you tried with other programs as well? Does the gestures not work in the same way?
Is there any that don’t work at all?


OK, so I only use other apps on a rare occasion. I pulled up Photoshop CC 2018 and it seems to be working fine. Navigating the web with Safari is also fine. So is it an issue with Clip Studio? The program itself is responding fine to touch input from my trackpad. If I pan and zoom on the trackpad, it’s responsive. When I use my iPad, it’s not.


Why would I pay $9 per month for a program I already own outright if there isn’t going to be any additional benefit? I happily pay subscriptions for Adobe products because overall, the product has been improved. PS and LR are more reliable, stable, and more frequently updated now. Unless Clip Studio is going to see that regular improvement too, I see no reason to pay for a sub. Not to mention astropad also allows me to work with Photoshop, Lightroom, a few other programs I use. I do use Astropad mostly for Clip Studio, yes. But the mobile version of Clip costs too much, has its own set of problems, and solves no problems for me. Astropad has worked very well for me until very recently, so I would prefer to find a solution.


@BenMatthews What version number of CSP is installed? Also Mac OS version?
With Astropad when you do zoom and pan gestures in CSP, does anything happen instead of the normal function? Does anything get activated instead?


Im using CSP 1.6.7 (I think). I just looked to see if there’s an update, and there was. So I’m updating it now and I’ll use it today and see if the issue persists. Mac OS version is 10.13.2. As for what happens, no, nothing unusual happens. Just nothing at all. Sometimes when I put two fingers down to pan or zoom, I’ll only see one red circle instead of two. Sometimes no circles. Sometimes I have to wait a second and then both circles will come up and it will work, but it’s very slow vs. the normal instant responsiveness. Anyway, I’ll work with the new version for a bit today and respond back.


@BenMatthews Let us know if there is any change with this.

If there isn’t a change, another thing to check when you use the Mac trackpad does it zoom and pan in CSP?
Is there any tablet drivers installed? Or any utilities or plugins?