Apple pencil pressure issue


Hey everyone,

I am using Astropad 2.0 on a 12.9" iPad Pro with an Apple Pencil and I am experiencing pressure issues in Photoshop CC 2015.5. Im having a hard time getting smooth gradients which can be seen in the attached picture. The top is on a Cintiq 13HD and the bottom is on the iPad Pro with Apple Pencil. I am running iOS 9.3.5


This happens with both a WiFi connection and a direct wired connection to my iMac


Please take a screenshot of your brush settings. This way, we can look into this further on our end.
Sorry for the inconvenience


Hi there,

Thank you for looking into this. Here are the brush settings. It’s the default hard round brush with transfer turned on with opacity set to pen pressure.


Checking further into this, we’ll need to improve and stabilize pressure sensitivity on our end in Astropad.

Something that may help in the meantime, is changing control for Flow Jitter to “Pen Pressure” as well.
It will not be as smooth as your top example, but lessens some inconsistency.

Thanks for bringing this to our attention, and for your patience.


Thanks for the reply and suggestion! I’m glad I could be of some help. Looking forward to what Astropad will bring in the future



I’m having a similar issue in Sketchbook Pro. It just started today.

I’m using macOS Sierra with an iPad Pro 9.7" and an  Pencil. I’ve tried with the direct and app store versions. Same issue.


@Malyse Have you see the above issue before?


Huge fan of Astropad (the biggest decider in buying an iPad Pro altogether) but this is the one problem stopping me from making a full time switch, I can only add my same issue to the conversation.

Hope this is something that can be fixed in time!


Thanks for the feedback and added image.
We’re currently looking into this issue with pressure, and hopefully will have improvements soon.


@Malyse Is there an earlier build we could try to test the pencil pressure issue? Like I told you, it didn’t begin to be an issue until I uninstalled Astropad and reinstalled. Perhaps an older build might hold the key to the issue?


@HYR We cannot provide older builds, but we are looking into this on our end.
Thank you for your patience.


@Malyse Ok. But you are able to reproduce the issue, right?


@Malyse I had put a ticket in with Autodesk to see if it was an issue on their end. The support rep did some testing and found that it worked fine on El Capitan but not on Sierra. So it seems like the issue arose (at least for me) from the upgrading to macOS Sierra. The said they’d pass on what they found to you guys.


@HYR I just wanted to let you know that we are also in touch with Autodesk and looking into this issue. So far our testing also shows it happening on Sierra.

We’ll keep you informed! We’re digging into this.


@mronge Thanks! I appreciate all of your hard work on finding a resolution! :slight_smile:



I should note that my screenshot is not Sketchbook- it’s Photoshop and I’m running El Capitan.

Still a problem!


@Malyse @mronge I was hopeful today’s iOS (10.1) and macOS (10.12.1) updates would solve our pen pressure issue on Sierra, but alas it does not. :disappointed:


@KristianDuffy Thanks for the added details, and we appreciate your patience.
Have you tried changing control for Flow Jitter to “Pen Pressure” as well? It lessens some inconsistency.


@HYR Thanks for the updated details, and sorry that didn’t solve it :cry:
We’re looking into this, and appreciate your patience.