Unable to pan in Sketchbook Pro (8.2.3) with Astropad (2.0.5)


#1

Hello, I’m new to the Astropad community but I’ve been playing with the tool for a while. I’m using it with Sketchbook Pro currently and I’m noticing that I can zoom (which responds slowly) but I can’t pan at all. Is this a known issue or is there some explanation I’m missing? Thanks for this great tool!

– HYR


#2

What is the model and year of your Mac? OS X version? Also, what iPad model and iOS version is in use?
Are there any 3rd party plugins or drivers installed?


#3

@Malyse

Thanks for your help! Below are the answers to your questions…

Mac

  • OS X 10.11.6
  • mid-2014 MBP 15"

iPad

  • iPad Pro 9.7"
  • iOS 10.0.1
  •  Pencil

Drivers

  • The only driver I know I have installed is for a Wacom Intous 3.

Behavior

  • When panning (with two fingers) horizontally nothing happens.
  • When panning (with two fingers) vertically zoom in/out occurs.
  • When pinching zoom in/out occurs.

#4

@Malyse Any luck in replicating/figuring out the issue I’m experiencing?


#5

We’re not able to reproduce it on our end, but I’m wondering if something is conflicting with that gesture.
Will send an email from support[at]astro-hq.com


#6

@Malyse I got your email and tried the command. That didn’t seem to work. I took a video and sent it back to you of the issue I’m seeing. Hopefully that will help you. I also tried removing the app on my iPad Pro and reinstalling it, which didn’t help either.


#7

Thanks for trying that.

On your Mac, what happens when panning using the Trackpad with Sketchbook?

Also, on your iPad with Astropad, if you using touch panning vertically in Finder window, are you able to scroll?

Again, thanks for your patience with this issue.


#8

@Malyse It doesn’t pan via the trackpad in Sketchbook Pro. Not sure if it’s supposed to since I’m new to Sketchbook Pro. :wink: I have to use the spacebar or one of their tools to pan around Sketchbook Pro on the laptop.

In Finder, using Astropad, I can pan vertically just fine. Actually I can pan just fine most anywhere using Astropad, like in Clip Studio Paint, Affinity Designer, any browser, Mac App Store.


#9

I have the same issue. Macbook Pro 10.12, iPad Pro 12.9
I cannot pan or rotate in SketchBook. Though I can do that with my Intuos Pro in SB no problem. Help!


#10

@Jt_Lanius Are you able to pan with your Macbook Pro’s trackpad when using Sketchbook?


#11

Turns out it’s a SketchBook issue. The solution they offer is to downgrade to v8.11 for now. Worked for me.
Here’s the link - https://help.sketchbook.com/knowledgebase/trackpad-canvas-issue-macbook-pro/


#12