Problem swapping between stroke and fill in Illustator


#1

I’m just starting to explore using Astropad with Illustrator and I’ve hit a strange snag. - I’m using an iPad Pro with Apple Pencil and while everything else on the screen works fine when I tap with the Pencil, there is one thing I seem unable to do: I cannot swap between fill and stroke using the toolbar controls -

I’ve tried tapping multiple times, tapping hard and soft, tapping and holding - all to no avail. (Although I have realised that double tapping brings up the colour picker dialogue, just as a double-click would, but only for the currently foregrounded option.)

I’ve set up a workaround by modifying one of the Astropad sidebar buttons to do the swap (keystroke “X”), but I still find it mysterious and frustrating that I can’t do this by tapping on the toolbar.

Have others encountered this issue? Am I missing something basic and obvious?


#2

What version of Illustrator are you using?
We’ll look further into this on our end.
Please send us a video of this happening, support[at]astro-hq.com


#3

I’ve had the same issue. I created the x sidebar button and it does the trick but any insight into why it doesn’t work without it would be great. - I’m using CC2015


#4

Oh goodness, is there any update on this? This seems like such a great program but if I can’t do this simple thing without getting to my keyboard it all seems useless…


#5

We’re still investigating, and figuring out a workaround to this issue with Illustrator swatch selection. When the swatches are in list format, this seems to more likely happen.


#6

Hey guys!

Just chiming in on this.

I also seem to have the swatch selection bug in Illustrator CC, the latest version, 2015.3 or whatever and the shnazzy new Astropad 2.0.

I am glad you mention that swatches in list view are more likely to suffer this bug Malyse, so i tried icon view and i can always select them that way, phew!

I can also switch colour from fill and outline with pencil no problem however I also cannot switch between which of the two are in front, gotta switch to trackpad or select colour and swap it with X.


#7

Thanks for the added info on this :slight_smile:

This is an inconvenient problem, and we’re narrowing on what may be causing this.
We appreciate adapting your settings around this issue; as well as the patience.


#8

I’m having this issue, as well. Can’t seem to be able to toggle from stroke to fill by tapping either.
Secondly, when trying to duplicate geometric shapes, especially small ones, with the option drag method it instead either rotates my object or destorts it. It’s the same scenario when I simply want to move or scale the object. These things are easily achievable for me with a mouse but near impossible with the Apple Pencil. Any help is appreciated.


#9

Apologies for the inconvenience.
What version of Illustrator are you using so we can test on our end?


#10

Thanks for getting back to me! I have been using CC 2015.3.1


#11

Hi, is there any further comment on the fill/stroke selection issue in the above? I have the same issue, selection doesn’t work with the pointer. I’m able to toggle hitting x on the keyboard which is fine for most of my work, but then I’m tied to my desk essentially. Latest Astropad (downloaded today), latest Mac OS, latest Ilustrator CC. This thread looks to be several months old so I’m hoping…


#12

Same issue. Mac OS 10.11.4, Illustrator CC 2015.3, newest Astropad version, iPad Pro, Apple Pencil. I moved the toolbar to the middle of the screen to make sure it wasn’t some problem with the edge of the screen, but same results - can’t switch to stroke.