''Pixelly" Lag?


i use ipad pro 12inch and mac pro tơer 5.1 . Astropad so laggg when i use it with Affinity app and Adobe app also . Please make a good update , because there 's no choice at this tine

i shooot a video about the laggg pixel here .


I just bought Astropad and I am having the same issues with pixelization.

I am running a iMac 27 Late 2013 with 24GB of memory running El Capitan (10.11.5) 3.2GHz iCore 5 with a brand new iPad Pro 12.9 256GB.

I purchase Astropad so I could do some retouching work on Photoshop.

The first time I ran Astropad it seems to work perfect. Then…

I started to run it again and whenever I make a selection with the selection tool parts of the image and parts of the program gets pixelated.

I need to know if this is normal or if there is something I can do to avoid it.



I bought my whole mac/12" ipad pro setup based on the reviews this app had, but once I tried it I gotta say it’s terrible. I’m using wired on a latest 15" macbook pro and its’ still terrible. I’ve tried all the tricks mentioned earlier in this thread but they don’t help at all. There is no way I can do professional work with this. I would ask for my 20 bucks back but I fear I’ve wasted more like 3000 because of this. Silly me.


Another one here. Bought the iPad Pro based on this app´s reviews, and I am returning the iPad now, to buy a Cintiq instead. With Photoshop, there is no way to just “deal” with any kind of lag or pixelation.


What version of Photoshop are you using? I have tried your hint, but ants is still marching.


When exactly this update will be released?

Thank you


You should see an important update by the end of summer, and more improvements by the end of the year. This is priority #1, we actively working on new alien technologies for Astropad. :wink:


the app is rediculously pixellated - Ipad pro and latest macbook pro…


We just launched version 2.0 which drastically reduces pixelation.
We are still working super hard on our image technology and we will keep pushing to minimize and eventually eliminate pixelation.

Let us know how this new version works for you,

Giovanni Donelli
Cofounder & Head of Product


Still there just bought the iPad Pro setup and thought I must be doing something wrong until I saw this thread. Anymore updates coming soon…???


@Aurther_Fonzareli What is the year and model of your Mac? Also, what programs are used with Astropad? Is connection mostly with USB or wifi?

We are constantly working to improve performance and reduce any lag.


2010 Mac upgraded to 8g ram, 250g hd, 256k processor and new g card. Running off of USB mostly as it seems better than wifi to a 128g iPad Pro 12". I am having problems with menu pixilation with both artrage and Clip studio paint ex. I hear there may be an upgrade coming at the end of the year, any truth to this?


I am looking at trying a better FireWire USB cable than comes stock as well but wondering if anyone else tried this before I buy one?


All right, I forgot leave a review in the app store but I always recommended it to all my local friends.


Try turning off “Use Retina” in Astropad.
Go to Astropad’s Preferences, then go to “Advanced” tab and uncheck “use Retina resolution when available”.
Is it only pixelation in the menus? Not the drawing canvas?

Both programs menus are not in retina.


I have the same issue a slight jittery while drawing but just a blur when using menu. Retina display is off as well and using USB not wifi


Try a shorter USB or thunderbolt they seemed to help but not completely fix the issue.


2011 MacBook, I use studio clip and artrage

From Kevin to you


I’m running photoshop on my tower, a Mac Pro 3,1 with USB 2.0. Yes, it is slower and having USB 3.0 is better. My workaround has been using wireless. It’s actually faster! I think that was the developer’s point of focusing on the Wi-Fi experience, to make the app suitable regardless of your USB port version. I don’t use a lot of marching ants, my workaround is doing a flat silhouette on a layer, then locking the pixels after cleaning it up a bit. that becomes my layer shape. No marching ants needed. If that is too much of a headache, you can always use command+H to temporarily hide the marching ants while you paint. This command toggles on and off so hit it again to show the ants if you need to.