Photoshop brush not releasing (iPad Pro)


#1

Hello -

I’m on the iPad Pro using Astropad, Apple Pencil and OS X 10.10.5. Sometimes Photoshop doesn’t “release” the brush and continues to draw without the pencil touching the screen. This also happens while using “Finger” mode. This does not occur in Pixelmator. I tried deleting iPad Astropad and reloading it. All other apps are closed on the iPad. Astropad on the Mac has been updated to: Version 1.3.3 (121).

I took a little video, and have posted a jpg.

Any suggestions would be greatly appreciated.

Here’s a link to the video:

Thanks!
Joe


Photoshop brush jumping from last cursor position
Not registering pencil correctly
#2

Hi Joe, this is the first time we see this.

Couple questions:
On your iPad do you see the same artifact in the “Magenta Line” Astropad uses to preview the stroke?
Do you have any special software installed on your Mac?
any wacom drivers?
any stroke plugin for PS?

Thanks!


#3

Hi Giovanni -

Actually…This anomaly went away after the computer (and iPad) came out of sleep mode. Strange. It’s also strange that it was only happening in Photoshop.

I really do love Astropad.

On your iPad do you see the same artifact in the "Magenta Line"
Astropad uses to preview the stroke?

  • No

Do you have any special software installed on your Mac?
any wacom drivers?

    1. Wacom Bamboo drivers and 2) The regular “professional” Wacom drivers 3) MagicPrefs (to create a middle mouse button on an Apple Magic Mouse)

any stroke plugin for PS?

  • No stroke plugins

Thanks for your reply.


#4

Okay cool, let us know if it shows up again


#5

Hi there!
I just got Astropad, and unfortunately I’m having exactly the same issue as the original post. with 95% of the strokes I make it draws a line from the previous position. I use it with the iPad pro, apple pencil, OS X 10.11.2 and Photoshop CS6.
unfortunately rebooting, or waking up from sleep doesn’t solve the issue on my end. I have Wacom intuos drivers installed, which behaves normally.
Any help would be great, I’ve been itching to play with this setup and this is almost like torture being so close :slight_smile:
Cheers,
-andré


#6

I haven’t been using Astropad frequently over the last month. I too have the Wacom drivers installed (version 6.2.15-3) and Photoshop (version 2015.1.1). The issue does return occasionally.

My steps to “fix” the problem while connected via lightning cable:

  1. Put Mac to sleep (Commmand+Option+Eject)
  2. Push power button on top of the iPad Pro
  3. Wake up Mac
  4. Push the round home button on the front face of the iPad Pro
  5. Everything reconnects and works properly

I hope this is helpful.

Cheers,
Joe


#7

Hi Joe,
Thank you for sharing your method! It didn’t work for me unfortunately, or any other combination of those actions.

I did get rid of the problem now. I started to remove 3rd party apps that were running, And I’m pretty sure removing “KeyRemap4MacBook” did the trick. I’m not sure if the newer version of that software (rebranded to Karabiner) will have the same issue. And I’m not going to try it either :wink:

Do you perhaps have that running on your mac too?

Cheers,
-andré


#8

Hi,

I was having this problem too. Exactly as Joe’s original video shows. I tried Joe’s suggestion and it didn’t work for me. Using André’s method of removing 3rd party apps eventually helped me out. I quit 3rd party apps one by one and the culprit (for me) turned out to be ‘Xgestures,’ a mouse gesture app that works well with Wacom devices. When I quit Xgestures, Astropad works in Photoshop without issue. I hope this helps someone else!

Cheers,
J.D.


Unexpected continuous line between strokes
#9

Just FYI here. I do have some third party apps that might be causing conflicts. These would be similar to users previously mentioned “gesture” type apps.

  1. BetterTouchTool ( http://www.boastr.net )
  • Used to create custom Finder shortcut keys.
  1. MagicPrefs ( http://magicprefs.com )
  • Used to create a middle mouse button for the Apple Magic Mouse.

Cheers


#10

Yes we heard that those are probably conflicting. Uninstalling those utilities usually fixes the problem


#11

Got the SAME problem here. It appeared to happen from the beginning when I installed your app. I don’t have any apps you mentioned above and I still have that problem and it seems to be unfixable - I tried everything. Also it’s not related to apple pencil - it happens even when you try a finger. Could you fix it somehow? it seems like that glitch is on your side.


#12

Just a quick update here. BetterTouchTool was causing the issue. When this app is shut down, everything works fine. Additionally, the MacBook pro is now running 10.11.5.

Cheers,
Joe
www.joeskibba.com


#13

Thank you for the added details! We’ll note this issue.


#14

When can you fix this problem ?


#15

@neolee.esp Which issue are you experiencing? Is it conflict with a 3rd party plugin? Or something else? Also, what programs are you using with Astropad?


#16

That issue with Better Touch Tools about not realesed brush

always continues brush from last realising


#17

@neolee.esp Unfortunately, this is an issue we will investigate further in the near future, but at the moment there isn’t a planned fix anytime soon.


#18

Do you seriously only use BetterTouchTool to create ‘custom Finder shortcut keys’? It can do way, WAY more than that - I use it constantly to navigate my computer, perform multi-step operations, manage windows, tabs, and to speed up my workflows of digital art and music production. It’s a very powerful and useful app and it’s sad to see you describe BTT as an app to add shortcuts to Finder…

P.S.
If you’re only using BTT for is keyboard shortcuts, you can actually add custom shortcuts for Finder or any other application in System Preferences…


#19

What do you mean when you say ‘NEAR FUTURE’??? It’s been 5 months… Really f*cking frustrating that your software doesn’t work as intended and promoted!!!


#20

Had the same issue here, it turned out to be SharedMouse software which caused that. Thanks for the clues around this issue!
I believe it worth to notify users about possible problems when astropad detects some of the mentioned software.