Palm Rejection issues


#1

Hi! I’m new to the community and to Astropad, this is my first month using it. I would love to open with a big THANKS for such an useful tool! I absolutely adore it.

Now here is my issue, I’ve tried to search for info before writing this post but couldn’t find anything useful or up to date.
I’m having problems with the palm rejection feature, for some reason it’s always detecting the border of my palm and where the wrist joins the hand, that little annoying bone (Sorry, English is not my first language so I don’t know the anatomical name for it lol). Problem is it creates random brushes strokes and clicks on the dock that leads to random programs opening on my Mac while I try to work. I does not happen always, sometimes after a few times of closing and re-open the app the issue stop but when it’s happening its incredible annoying.

Helpful info:
I’m working with Astropad Studio on an iPad Pro 10.5 running the latest iOS with a Mac running the latest High Sierra. When I’m not working with Astropad I use a Wacom (Current Driver 6.3.28-2).
I read somewhere Wacom drivers can lead to problems with Astropad but I can’t afford to uninstall my Wacom as I work with it everyday.

Edit. 5/13.
I tried to work today with Astropad and the bug is extremely annoying, the apps and files on the doc opened every time my palm was on it.

Uploaded and image of my working space here.

Any help is welcomed!

Thanks a lot in advance!


#2

Thanks for the details.
What program versions are you using for Adobe?

Are there any third-party plugins, utilities, or drivers installed on your Mac?
There are some that can conflict with Astropad’s input.

Relating to Wacom drivers, have you tried the latest version (Driver 6.3.29-6)?

Something you can try is a factory reset for Astropad—
Close Astropad’s Mac app.
Then hold Option key, while opening the Mac app again.
It will ask if you want a factory reset.


#3

Which stylus are you using? The Pencil should be rejecting your palm perfectly well, although third-party styluses have a much more difficult time with it (due to not having the tight integration).

I have a similar setup to you - using both AstroPad and a Wacom depending on location - and at least on the Wacom I find one of those Wacom-type gloves to be very helpful, and that should also help on the iPad. Here’s the particular one I have: https://amzn.to/2Ikjy1e


#4

Hi!

Took my time to reply as I wanted to test everything you mentioning for a reasonable time to give a feedback :slight_smile:
I did all and it’s working better! My guess is Wacom Driver interferes with Astropad somehow. Once it was updated I had less issues with the palm rejection feature though it stills happens time to time.
It happens more often with Photoshop CS than with any other Adobe program. As far for utilities or other drivers, not really, as I use my Mac only to work the programs I have are PS, AI, ID and AE from the Adobe Suite, Blender, Keynotes template plugins (all downloaded from the app store), Bitnami for Wordpress, and as for other Steam and Spotify. Could some of this program interfere in any way?


#5

I use an Apple Pencil. The globe is a great idea! Thanks a lot!
I will be using a Huion GT 191 (Similar to a Cintiq) will the driver affect Astropad in any way? What do you think?

Thanks a lot for the answer in advance :slight_smile:


#6

Driver conflicts are always possible, although it’s easy enough to find out. The Wacom driver was pretty notorious in the past for causing problems (especially with modifier keys) but these days it’s mostly been worked out. I have no idea about Guion though - off-brand tablets usually (in my experience) have very poor-quality and unmaintained drivers, especially on macOS.


#7

@Ciellchan Glad that things improved, and thanks for updating us on the status of this issue.
None of those plugins and programs listed should conflict.

Maybe something to see if there is any difference:
In Astropad Studio’s main sidebar menu, select “Magic Gestures”

Scroll below and select One Finger Tap. When disabled, only palm rejection should kick in and no tap single tap selection, instead. You can also disable Two Finger, Three Finger tap below it if needed.

Also, in the iPad’s Settings, go to General,
select Accessibility and make sure any of the Zoom settings are turned off.
This setting can cause conflict with palm rejection and input.