Not registering pencil correctly


I have just re installed studio after being on the beta for a few months without any issues. Unfortunately it’s now not registering when the pencil isn’t being removed. Instead it’s drawing a straight line between marks.
In the image attached I am just drawing circles the lines joining up the brush marks

I am running iOS 11 on an iPad Pro 12.9 and have installed the latest version of Astropad on both my Mac and the iPad with and without usb connection. This only seems to be happening in photoshop. I have also tried illustrator and sketchbook and here are both ok.


What version of Photoshop are you using?
Also, does the issue look something like this, or similar? - Photoshop brush not releasing (iPad Pro)

Is there a Wacom driver installed on your Mac? If so, what version number?

Any other third-party plugins or drivers installed on your Mac?

Something to try, is reset Astropad to default-

Close Astropad’s Mac app.
Then hold Option/Alt key while opening the Mac app again.
It will ask if you want a factory reset.

Also, maybe try resetting Photoshop’s preferences to default -
hold Option+Command+Shift as you start Photoshop.
Current settings will be deleted.


The link below is the exact same problem. It think Hej Stylus is the culprit as this is a new plug in since I last used AstroPad. I can’t replicate the issue now, it seemed to stop doing it after a cute of days. Thank you for your response. Hopely your link solved it.

Thanks you for your support and great app!!

Mark Levy
Traffik Cone Design
Mobile : 07855 383633