LightRoom or AstroPad Issue


#1

Everything was working fine until about 10 days ago when I started noticing what is either lag or another video problem when editing in Lightroom on my 2017 MacBook Pro connected via USB to my 2017 iPad Pro. When editing (with sliders or a brush), the screen flashes between normal and much lower contrast until I complete the edit.

As I said, this behavior is new and Lightroom has not been updated for a few months (far before this started). I am using Astropad Studio v 1.6 (2631) on my MacBook Pro and 1.6.1 on my iPad Pro.

USB Connection Quality: Highest
Response time: 2 or 3 milliseconds

The only other change that might have affected this is that I switched from an xWrite iDisplayPro to a DataColor Spyder 5 around the same time (but I am not 100% sure whether it was before or after the problem started).

Any ideas or suggestions on what to try?


#2

The color contrast of the entire screen keeps shifting? Or only the working canvas area?
Does this happen when you use the stylus on the iPad, or only when editing with slider, or a brush?

What Mac OS and iOS are installed?
Anything else new to you setup? Any attached external monitors?


#3

I think it is limited or mainly in the canvas (a little bit hard to tell as it is so distracting), but it appears ONLY on the iPad Pro display, not on my MacBook’s screen, even when I am using the Apple Pencil on the iPad Pro.

I only use the Apple Pencil, but it happens with the sliders AND with certain local brushes (the radial and graduated filter are the most prominent).

No new equipment other than the switch from Xrite to Datcolor Spyder (and it does not matter if the Spyder is connected or not). I have also tried using different USB cables and different 3.1c adapters–no change.

I have tried setting LR to use Smart Previews (maybe slightly better–not much). I have tried turning off the Graphics Processor on the MacBook (no change on the iPad). I have tried different levels of iPad display brightness, tried turning Wi-Fi and AirPlay off–no difference.

Mac OS and iOS are both autoupdated to latest versions. OS-X 10.12.6 (16G29) on the Mac, and problem happened with both the last version if iOS 10 and continues on iOS 11.0.2

  • J

#4

@Jeffrey_Morris Is Night Shift enabled on your iPad or Mac?
If you have one of the latest iPad Pro, is ”True Tone" setting on?

Thanks for all the added details, and we appreciate your patience.


#5

Indeed, True Tone appears to be the culprit, and apparently it is worse at different levels of brightness/room ambient lighting (which explains why it started happening–I changed working to a different room).

That’s really too bad–my iPad’s color is much closer to my calibrated monitors with True Tone on. Well, at least I know to use look at my external monitor (or my MacBook screen) to judge anything related to color/tone.

Oh… and Night Shift is off on both.

Thanks for the detective work.


#6

What versions of LR desktop and app are you using Jeffrey?


#7

LR 2015.12 on my MacBook. I’m not using the the mobile app on this iPad.


#8

@Jeffrey_Morris Another thing to maybe try, if you want to keep True Tone on,
might be to see if turning off “use Color Sync” in Astropad Studio does any difference.

In the sidebar, select “General settings” and under Color Calibration has this option.
https://blog.astropad.com/general-settings/

We’re noting this issue, as we’ll see how we can improve with True Tone enabled!
Thanks for your patience while troubleshooting :slight_smile:


#9

The flickering/latency problem is back! I have True Tone, Night Shift, and auto-brightness all turned off and nothing in my hardware setup has changed. Connected via USB at 2 millisecond response. The problem is severe in Lightroom and mostly minor in Photoshop. I see no difference whether or not I have LR set to use the Graphics co-processor or to edit from smart previews. I have also tried disconnecting both my Spyder Elite and my external monitor (using only my laptop and iPad Pro). My iPad is connected to directly (via an adapter) to a native USB-C port on my MacBook (not through a hub).

Thoughts… suggestions?


#10

@Jeffrey_Morris What Mac OS is used?

Does your Mac have a discreet graphics card?
If so, on your Mac in System Preferences - go to Energy Saver Preferences, and disable “Automatic Graphic Switching”.

Maybe try a Preferences reset for Lightroom.
How to do this - Press and hold the Shift + Option + Delete keys as you start Lightroom.

Something else to try:
Go to Astropad’s top menu bar, hold down the option/alt key and at the same time click "Preference"
This will enable the Debug tab, select it.
For “GPU Acceleration”, try seeing if there is any difference when setting Metal, OpenCL or CPU.