LG Ultrafine 5k Lag


#1

(I’ve also emailed this question to support and have seen a similar thread in the support topics. I’m posting here both because it consolidates a lot of that thread’s information and timestamps the issue as still ongoing)

Hello Astropad Team,

I’m experiencing input and/or display lag on my LG Ultrafine 5k display when using Astropad Studio and standard Astropad. The lag affects any input event that happens within the Astropad screen area when it is on the LG display (regardless of whether my MacBook Pro is in clamshell). Is this a known issue that occurs across all LG Ultrafine displays, or is it possible something else is going on?

Hardware / Software:

  • 15” MacBook Pro 2017 (Touch Bar)
    • macOS Sierra 10.12.6
    • 2.9 GHz i7, 16 GB RAM, 1 TB SSD, Radeon Pro 560 4 GB & Intel HD 630 1.5 GB
    • Astropad Studio (beta)
    • Astropad (standard version)
  • iPad Pro (12.9” 1st gen)
    • iOS 11 Public Beta 4
    • Astropad Studio (beta)
    • Astropad (standard version)

Also separately tested on an iPad Mini 2 (Studio non-beta) and iPhone 7 Plus (Astropad Mini) that are running iOS 10.3.3 and yielded the same results.

What I’ve tried so far:

  • tried connection via wi-fi, connected directly to Mac, and connected via the monitor’s USB
  • tried with and without Apple Pencil connected
  • restart Mac (several times)
  • restart iPad Pro
  • disabled “Retina” within Astropad Studio’s preferences
  • disabled “ColorSync” within Astropad Studio’s preferences
  • updated monitor firmware and software, followed by a restart
  • disabled / enabled monitor software
  • lowering the monitor resolution output
  • clamshell and non-clamshell mode
  • removing USB connected devices
  • quitting all other open apps
  • quitting some helper software for other apps
  • uninstalling some helper software for other apps
  • turning off bluetooth / disconnecting bluetooth devices

Any guidance or information about fixes for this (or future updates that will fix this) is greatly appreciated.


#2

We have that exact configuration and we are also seeing this.
We even talked to Apple about it, but no luck.
We don’t have a solution at this moment but we are actively investigating it.


#3

Hi guys -

I too have the same configuration (only difference is Ipad Pro gen 2) and experience unusable lag when Astropad is running off my LG Ultrafine 5k. Crossing fingers for a fix, it’s a real bummer - otherwise awesome program!


#4

I hear you ;-( the workaround is to unplug the LG screen for now.
I know it sucks. We are looking into it, but we haven’t found the source of the problem as of yet.


#5

For what it’s worth, I can still have a lag-free Astropad experience while connected to the LG Ultrafine monitor, as long as Astropad isn’t reading from the Ultrafine monitor. While this prevents me from working with the MacBook Pro in clamshell as I had been, I don’t really mind it. I made a script to turn my MacBook Pro’s brightness all the way down, which is my typical use case now (contrary to the photo I uploaded).

I truly appreciate the responsiveness and ownership of the issue, though. Looking forward to future developments, even if this issue ends up being unresolvable.