Keyboard commands getting stuck (photoshop)


#1

Am i the only one having problems with the CTRL, ALT, CMD keys in photoshop , using astropad?
My keys gets stuck, like for an example if i colorpick holding ALT, and i release ALT, it continues to still be in colorpicker mode instead of returning back to the previous tool. if i click one more time on ALT it returns to the previous tool…
This seems to happen using both my built in keyboard on my macbook pro late 2013, or my apple wireless keyboard.

It does not seem to happen that often if I use astropads own virtual CTRL,ALT,CMD keys… I think it happened once or twice perhaps though. I tried disabling my wireless keyboard using only the built in one but problem still is there.

it does NOT happen in Clip Studio, it seems limited to photoshop… My only work around is to ALT click my color and then ALT click again, so basically double clicking everytime…
I can imagine most people dont notice this bug if they mostly do line work and simple color fills, but for painters who need to ALT - color pick very often…its very annoying.


#2

I had that too. Traced it down to the latest Wacom drivers not being compatible with macOS Sierra. I regressed to an earlier Wacom driver and the problem stopped.


#3

Note that Wacom have pushed out a new driver update that fixes the problem. Make sure you’re running version 6.3.19-10 or newer.


#4

I have the latest Wacom drivers and latest Sierra, still get the bug.

Just to clarify, if i use a mouse in photoshop just using astropad as a display, i dont get the bug.
And I dont have this bug when I use my Intuos 4 Tablet. This is only with Astropad.

also not sure why a wacom driver would affect the Apple Pencil & Astropad ?


#5

I’ve reported this before, seems Astropad is aware of the issue and hopefully will have a fix out soon:


#6

I am watching this bug in Photoshop for almost a year. I draw fast and often change color. When taking color by eyedropper tool command keys constantly getting stuck . This is very annoying and disappointing, it does not let me to work normally. Also having same problem with other command keys.

Please fix it. Thank you.


#7

The problem I was having was that the modifier keys Cmd, Option, etc were getting stuck sporadically, whether using Astropad, MacBook keyboard, whatever. The problem was traced down to Wacom tablet driver not playing nice on Sierra. That’s what it had to do with it. As I said, I regressed my Wacom driver and haven’t seen the problem since.


#8

I am having the modifier keys getting stuck on my MacBook Pro 2017, iPad Pro 9.7 and Photoshop when working on Astropad Studio. Using the built in keyboard or apple wireless keyboard makes no difference. I was having this problem with Photoshop and my Wacom Cintiq but I reverted to Wacom Driver 6.3.15-3 and the problem disappeared when working with the Cintiq.
I went away with my laptop and iPad last weekend and I used AstroPad Studio to do some changes to a job. The option key kept getting stuck while using it to bring up the colour picker which I do constantly. So after I pick a colour I have to hit another key like the space bar to release the key before I can go on drawing. Also when using the Option + Command shortcut to resize the brush. I actually deleted the Wacom software from the laptop to see if this would clear the problem but the stickiness persisted. When I came back I re-installed the Wacom driver and tried using the modifier keys with Photoshop and my Wacom and everything worked fine. But I then tried Astropad Studio again and the sticky problem continues. I shut down my iPad and it has not disappeared on restart. So I’m actually not sure what’s going on! Basically it makes using Astropad Studio feel very disjointed at this point.


#9

yeah i think its very clear it has nothing to do with any wacom drivers.


#10

No, not “very clear”. There are definitely issues with the Wacom drivers. There may be other issues, with Astropad and/or other things, but at least for me, Wacom drivers were a major issue. THE issue for me, but obviously if that is not a satisfactory answer for you, continue discussing.


#11

Still having this issue here, don’t have this issue on my wacom tablets at all yet seems to be happening non stop on astropad. Tried on two different computers, and have tried uninstalling and downgrading wacom drivers with no luck.

Currently have to press ‘b’ to jump it back out of using Ctrl+alt brush size shortcut. Absolutely infuriating! :frowning:


#12

Yeah, I’m seeing a new issue now that I do not believe is associated with Wacom. The space bar is getting stuck during prolonged high zoom editing. Had to shut down Astropad Studio and Photoshop to settle things down.


#13

yep… i still have the issue, with both astropad and astropad studio which has led me to stop using the apps completely, it got too annoying to use for production work.
It’s definitely happening less now with the newer versions, but still happens. Maybe it has something to do with performance? When i feel the computer is getting a bit laggy, this bug happens more frequently to me.

If I use just on-screen touch controls, i do not get the bug I believe, or it happens way less, but I need the keyboard to be effective.


#14

We’re looking into this, and need further details to help us figure out the cause of the stuck keys.

Please provide this info:

  • Are you using Astropad Studio or Astropad Standard?

  • Mac OS version

  • iOS version

  • Does this happen on both your Mac keyboard and Astropad’s on-screen keyboard/quick keys? Or only with the Mac keyboard?

  • Does this only happen with Photoshop? If so, what version of Photoshop is in use?

  • Wacom driver version, if one is installed.

  • Please try this: On your Mac, go to “System Preferences”, then “Keyboard”. Try setting “Key Repeat” to off. Does the problem still happen when using Astropad? Let us know the results.


#15

Thanks for looking into it.

  1. I have both studio and standard, and i get the problem on both.
  2. macOS Sierra v.10.12.3
  3. IOS, latest. (10.2.1)
  4. It only happens with my Mac keyboard, not using on-screen touch controls.
    5.It happens in both Photoshop and Clip Studio for me. But less in clip studio for some reason. I use CC 2017 photoshop, and the latest Clip Studio.
  5. Wacom driver is 6.3.20-4

I tried the Key Repeat Off, it did not change anything.


#16

I have always had issues with modifiers getting stuck (alt & ctrl) in Photoshop, but never in Clip Studio until this last update to the Mac app.

  • Using Studio
  • macOS Sierra 10.12.3
  • iPad Pro 9.7" iOS 10.2.1
  • Only MacBook keyboard, not gestures.
  • Problem happens in Photoshop CS6 & CSP.
  • I uninstalled all other tablet drivers & I’m still getting the issue.

This is extremely annoying, and I’ve gone back to my Wacom tablet until this is fixed.
Please let me know when this is fixed.


#17

I too am starting to get sticky keys with alt & cmd in Clip Studio using Astropad Studio. At first I thought it was my gaming keypad that I was using for hot keys, but now it is happening occasionally even with a regular keyboard, and even Astropad’s built in shortcut keys. I often us the keystroke opt, cmd, pen drag to resize my brushes and it has been getting stuck very often lately.


#18

I’ve downloaded keycastr and according to that the keys arent still being logged as held down. I’ve found that this mostly happens & is reproducible then the keys are released at the exact same time as the pen leaves the tablets surface. I’ve been digitally painting for years now and my use of hotkeys is just fast muscle memory at this point, I obviously release both at the same time and trigger this most times I’m using the eyedropper or scaling by brush in photoshop.

Ipad 12.8" running 10.1.1
Mac on 10.11.6
Astropad pro
I don’t use the on screen keyboard
Mostly seems to be photoshop, orbit tool in maya for instance doesn’t get stuck despite the same key gluing to the eyedropper in photoshop
photoshop 2015.5.1