Jot Touch 4 & Ps CC Pressure Sensitivity/Connectivity Issues


#1

Hi. I’m using the Adonit Jot Touch 4 with iPad 3 in Photoshop CC 2017 on a 2011 iMac 3.4 GHz i7, 16 GB RAM, AMD Radeon HD 6970M 2048 MB graphics.

I am constantly getting the red X when trying to draw, erase or use the color picker using Photoshop CC 2017.

Another user with a similar issue suggested changing Photoshop performance settings to Basic, which helped slightly, but the red X still appears too often to make Astropad a useful interface tool.

Any ideas or suggestions would be deeply appreciated. I (almost) love Astropad!

Thanks!
-Anthony


#2

Hi Anthony,

The red “x” is usually an indicator of palm rejection,
but can randomly occur sometimes because of the stylus.

On your iPad, try turning off and back on bluetooth. Sometimes that restarts connection.
Also, try turning off bluetooth on your Mac, if it is enabled. Sometimes the signal conflicts.

Have you tried removing, then pairing the Jot Touch 4 again?
Re-syncing the stylus can help reestablish connection.

On your Mac, go to Astropad’s preferences, and click the “Stylus” tab. At the bottom of the window, click “Remove stylus”. Then try pairing on your iPad again.

Let us know if the red “x” still persist after trying this.


#3

Hey there.

Thanks for the quick response.

I have tried all of these suggestions with the same reoccurrence of the red “X”.

Here’s a link to a quick video example of what I’m experiencing:

Regards,
-Anthony


#5

Hi Anthony,

Thanks for the video.
When you press down, applying more pressure, does the red x happen more or less?
Same question for when you draw with lighter amount of pressure?

Also, check the disc; wondering if this relates at all to the disc being loosen and/or causing further inconsistency with the stylus.


#6

Hi Malyse,

I checked the disc, replaced it even, with the same problem… But…! Then I replaced the ENTIRE TIP, the disc and the shaft it attaches to (didn’t know I could do that), and…

Now it works flawlessly! It was my stylus after all. Should have know it was the culprit since it was behaving erratically in Procreate as well.

Thanks for your help and your patience! Love Astropad!

Best,
-Anthony


#7

Hi Anthony,

Thanks for the update, and glad to hear!!
At least it helped narrow down the issue :slight_smile:

Always feel free to contact us with questions or feedback.

Best wishes,

Malyse