HOLD sidebar and stylus modifiers?


#1

My hope is that I’m just missing something… I use Sketchbook Pro. I need to have the ability to hold modifier keys like the space bar and the “i” so that I can move the canvas and use the eyedropper. It seems that in both the sidebar and the stylus buttons (wacom intuos CS1), it registers as a quick button push and has no option to hold.

PLEASE tell me I’m missing something???


#2

Hmm, we need to look into this. I’m going to investigate and try it with my Wacom CS1.


#3

Thank you! Can’t wait to hear more :slight_smile:


#4

Ok I can confirm the problem here as well.

I think this is an Astropad bug. We are going to look into it for you!


#5

Is the same expected of the ‘hot keys’ on the ipad screen? Any shortcuts I make there are treated the same way. I really need a way to use the space bar as a HELD key in sketchbook.
Regardless of this, I ended up buying the software this weekend. Thanks for such an awesome product! Now I just have to convince the wife to let me upgrade back to a full size iPad :wink:


#6

Thanks for your support! :smiley: I use Astropad on an iPad Air 2 and it’s excellent. Once Apple releases the iPad Pro it will really be something.

Yea, in general the shortcuts are triggering a quick button press and not a hold like you need.


#7

Has there been any progress in a ‘fix’ for this? Or… did I mis-judge your response? Is the team working on a change to the behavior?


#8

I’m sorry, we haven’t fixed it yet. :frowning:

We’ve been overwhelmed with support, marketing, other bug fixes etc. We will get this fixed though! I’ve got it noted in my bug tracker


#9

Don’t get me wrong - I’m happy with all the other stuff you guys have been doing. I was just checking in :smile:. Thanks for the update, can’t wait to see that part working!


#10

Just wanted to check back on this as well. It’s been about 5 months and, for me, the button-hold is still not working. Maybe I just missed something? :neutral_face:

It’s pretty essential to my workflow and the apps I’m using… :slight_smile:

Cheers,
Tim


#11

I haven’t seen a change either moeptier. I was able to pick up the iPad pro and hope this is resolved before I am able to find the Apple Pencil (so they have a couple months yet - sigh).
Regardless, I still love this product!


#12

Seconding @moeptier - This is definitely something that I’d need fixed before using AstroPad regularly. Alternatively, making the overlay buttons customizable, since holds there do seem to work. Thanks!


#13

I would like to see that option too.
I just bought astropad and i need this feature so badly.
Please give us this option.


#14

Wanted to add my request to fix this. Would make a great app even better.


#15

Still waiting here for a solution… What about being able to change one of the modifier keys that show up in the palette? I have no need for the shift key :slight_smile:


#16

This is also an essential feature for me. A space bar modifier would make the difference between me using Astropad and not.


#17

This thread was started about a year ago. Is there an option to configure a shortcut to use a hold action?

Thanks,
Jim


#18

Unfortunately, this option is not available yet. Still work in-progress.
We appreciate the patience.


#19

Is this still being worked on? I want to invest a MacBook just for Astropad + zBrush, but there needs to be a way to hold modifiers like space, and press and hold multiple modifiers at once, but it seems like there’s no support for it?

Edit:

Opps, looks like this is 2 years old! I’m assuming this was implemented? Could someone please confirm :slight_smile:


#20

Not sure if this is answering your question, but I can use keyboard shortcuts concurrently with astropad’s stylus input: for example I can hold the spacebar pressed on my imac’s keyboard and at the same time drag my apple pencil on the iPad’s screen. In mischief app this successfully causes the canvas to pan. Or I can hold Shift+space on my imac’s keyboard, which allows me to rotate the canvas with my apple pencil. Just like I’d do with my wacom.

I can even set shortcuts inside Astropad and do the exact same thing without ever touching my imac’s keyboard - merely using the on-screen modifier and shortcut buttons inside Astropad for iPad.

What seems to be not working properly, is the following scenario: use the iPad’s on-screen “shift” modifier key, combined with my imac’s (physical) “spacebar” key - this combination seems to ignore the “shift”! The opposite however works: Using The “spacebar” shortcut on the iPad combined with the “shift” key on my physical keyboard registers as shift+spacebar - strange, but unimportant IMO!

tldr, as long as you use either the on-screen shortcuts xor the actual keyboard of your mac (and don’t mix), it’s working fine! hope this helps!