Glitchy strokes with Astropad and Apple Pencil (iPad Pro)


#1

I just picked up an Apple Pencil today and have been taking it for a spin in several of my apps, and I’ve been disappointed to discover a strange behavior when using Astropad in both Photoshop and Clip Studio Paint. Strokes are exhibiting a weird “blow-out” effect at one or both ends, particularly with light, quick movements. The result looks something like this:

I understand that Astropad for the iPad Pro is still in beta, but I just wanted to bring this to the developers’ attention! Is anyone else experiencing the same issue? I’ve seen the video that’s been linked elsewhere with an artist testing Astropad on the iPad Pro, and it’s unfortunate to say the least that I haven’t had the same excellent experience! :frowning:


#2

Hi!

I’m sorry you’re having glitchy strokes :frowning: We definitely want to figure this out.

What version of PS are you using?


#3

Thanks so much for getting back to me! :smile:

I’m using the latest version of Photoshop CC (2015.0.1 release) on OS X 10.11.1. The same problem also appears using Clip Studio Paint (Pro, version 1.3.8), though I’m not sure if that app is “officially” supported with Astropad in the first place!


#4

Hi,

I was just playing around in Manga Studio and Photoshop trying to reproduce the bug and I can’t :pensive:

What version of Astropad do you have on your Mac? Go to the Astropad menu and choose About to see what you have.

Also, any chance you could make a quick video recording of what you’re seeing? That way we can see the precise steps to reproduce.

Thanks


#5

I’m running version 1.3.3 of Astropad on my Mac! Here’s a quick video–I hope it helps! I’m using a 90-pixel basic soft-edged brush with pressure sensitivity turned on, drawing quick, light strokes.

https://vid.me/bnLI

If it helps, I’ve tried making these types of strokes in other iOS apps, and while the blow-out effect isn’t occurring, they also aren’t producing the intended effect. The pressure appears to be averaged out in software to produce what’s basically a dead-weight line from end to end instead of a nice tapered one. It has me wondering if this might just be a limitation of the hardware compared to what I’m used to (I work primarily with Cintiqs).


#6

Ok thanks that was very helpful, I’m seeing that now too after following your steps.

We’ll keep looking into this and get back to you


#7

I’m having the same problem with Astropad, among others:

  1. I can’t get photoshop to recognize any pressure sensitivity.
  2. the glitchy (blowout) effect shown in the original poster’s video. Note that I also see this effect in one app on the Ipad pro itself – medibang paint (japanese manga drawing program). That app has a great set of features and the problem is not pronounced, but it suffers from the same “blowout” phenomenon on the beginning of all strokes. Procreate has no such problem, so i assume it is something with the app’s algorithm for how it handles stroke inputs from the apple pencil.

#8

I am also having the same problem as ara-mia. Same specs and problem.


#9

Hi everyone,

I just wanted to give a quick update on this bug. After lots of tinkering with Apple Pencil we’ve been able to determine what’s going on. We’ve put together a fix that we are testing and will be available soon in an update to Astropad.

Thanks again for the feedback


#10

Interesting, the same issue was reported in the Procreate app’s forums: http://procreate.si/forums/index.php?topic=7628.msg71115#msg71115

Glad to hear a solution is in the works! Seems like a lot of teams have had to contend with this issue.


#11

We have fix pending Apple Review. It will be out in about 2-3 weeks


#12

That’s great to hear. Out of curiosity, can you share at all what sort of problem it was? It’s interesting that it was showing up across apps. Is it a hardware issue, an OS issue?

Thanks.


#13

User Atomic Walrus on the MacRumors forums has done some research into the problem–seems like there may be some glitchy API code making the rounds. I was able to replicate this bug in quite a few Pencil-supported apps, including Procreate, Medibang Paint, and Adobe’s apps (Sketch and Draw in particular). So it does appear to be pretty widespread, though it’s not universal. Hopefully other developers will be as proactive as Team Astropad have been in tackling the issue! :smile:

Thanks so much, dev team! I appreciate it!


#14

Hard to say exactly, but probably a combination of Hardware and Software.
The update should be our just before Xmas eve!


#15

FWIW I just replicated in Made with Mischief. I hope the update fixes it, otherwise I may need to return my iPad pro.


#16

We are pushing the update out in the next 48 hours. You will know very soon


#17

I am Having this same issue with Photoshop CS6 2014 macbook pro https://scontent.fsnc1-1.fna.fbcdn.net/hphotos-xpl1/v/t34.0-12/12404499_935666619844511_462620218_n.jpg?oh=ce66ea144f696caad77521fd77ac68b7&oe=567981E3


#18

Update Astropad the fix is out


#19

it definitely fixed the problem quite a bit but i still seem to be getting a dot at the beginning of my stroke no matter how soft i touch the screen…will these problems continue to get worked out?


#20

Definitely we are always work on making it better!
Can you post a new image of what you see now?