Canvas Zoom/Pan on iPad Pro not working



I am new to Astropad. Love the responsiveness and flexibility afforded by Astropad!
I realise that Astropad for iPad Pro is still in beta, but I am not able to zoom or pan the drawing canvas using the two finger gestures for zoom and pan. When I use the pan and zoom gestures, the app shows the relevant icons for zoom and pan on the iPad, but the actions are not taking place.

So far I have tested this on Mischief and SketchBook Pro (I do not have or use Adobe Photoshop).

Perhaps I am missing something in the set up? I have already selected Apple Pencil as the stylus, and that is working fine…

Thanks in advance for your help!



How is everything else working with Mischief? That is one of the programs I look forward to using with the iPad pro when I get things set up…


I love the idea of Mischief. Infinite canvas is well executed and the brushes are great. I use it for storing ideas.

I haven’t been using Astropad much due to this issue. However pressure sensitivity and latency are fine.


Zooming and panning canvas are setup different for Mischief and Sketchbook, compared to Photoshop.
We are improving the 2-finger pan and zooming to be compatible for other apps, so expect that in the near future.

You can change the sidebar shortcuts, in the meantime.

Apologies for the inconvenience, we appreciate the patience.


I have the same problem in Lightroom. Pinch gesture or move of two fingers changes the size of the Adjustment brush, but no luck to zoom or pan. No matter whether I am in Finger or (Apple) Pencil mode.


Interestingly, panning works when I’m in the Develop Module but the Adjustment Brush is not yet active. Then when panning with two fingers the canvas moves, but the pinch gesture to zoom still doesn’t work. It seems that somehow the panning gesture (drag with two fingers) is configured to do the same thing as the scroll wheel of the mouse does. I guess this is because that’s how it works in Photoshop. So many things in Astropad are optimized for Photoshop but not for other applications, where such mappings are different. I didn’t find out what’s the problem with the pinch gesture to zoom but I guess this also has to do with how it works in Photoshop, but not in other applications. I think it has something to do with the Space bar, but I couln’t find out more.


Same issue here when using Astropad with Sketch on the Mac.

Sidebar shortcuts for zoom in/out work great

pinch to zoom in/out does not work at all

two finger canvas dragging works but is very slow…


New to Astropad yesterday and in general love the fact that I’m in my living room with the family editing an image in PS 50 feet from my Mac. Still learning the interface, but I’m having problems with the pinch zoom and pan as well. Sometimes it works and more often it does not. If for example I am using the healing brush and I try to two finger pan it will do a healing brush on one of my two fingers movement. I don’t have an apple pencil yet ( waiting for that to be in stock ) so I am using a non pressure sensitive stylus in the mean time. I have played around with finger spacing and angles trying to find a consistent winner, but no luck yet, it’s still seems quite random when that function wants to work.
So far that is the only thing other than not having an apple pencil yet, that has been frustration me.
Anyone found a resolution yet?


Today I started with Astropad, IPadPro and LR and PS CC. I also have the issue with zooming of my canvas. It still doesn’t work. But this feature is so important. Is there a workaround about that issue? When it would be solved?


I am having the same trouble with the zooming. Any news on this one yet? :slight_smile:


@Kyub Which programs is touch zoom not working? And what happens instead, when you try to use touch panning and zooming?


Zoom in and out pinching gesture is working perfectly in Photoshop, but not in Illustrator. It would have been convenient if I am not dependent to the shortcut button for zoom in/out and can replace it with another command.


@Kyub What happens when you try touch zoom in Illustrator? What version of Illustrator are you using?
If you have a trackpad to test, does zoom work with it?

Is scroll reverser enable for a mouse?