Astropad keeps moving on display


#1

Hi, I’m using astropad in one location on my monitors but astropad keeps moving when it restarts. It doesn’t happen every time that it restarts, and not exactly sure what the impetus is, but happens frequently. I keep astropad in the bottom left of my 3rd monitor and frequently find it in the middle of my 3rd monitor, even though i never put it there.

I want to make it just stay in one place all the time. Or make a keyboard shortcut/midi macro button to put it back in one spot quickly.

How can i do this?

Thanks, Dan


#2

Hi Dan,

When it sets itself in the middle of the 3rd monitor, does it resize as well?
Or stay the same size you set it previously?


#3

Hi Malyse, it seems to resize as well. It also moved to the 1st monitor this morning.


#4

I also sometimes notice Firefox moves up to the 3rd display, and i always keep firefox on the second display. Sometimes another app (called resolume avenue) also moves from the 3rd display (where i keep it) to the second display. Not sure if these are relevant to the discussion and my goal is still to just fix Astropad, but sharing in case its helpful to diagnose


#5

Hi Malyse, have you seen my replies to your comment? I’m still trying to figure this out and would really appreciate some advice! :slight_smile:


#6

Hi Dan,

Thanks for the added info, that help us look more into what could be happening with this.

In your Mac’s System Preferences, select Mission Control
Is “Automatically rearrange Spaces based on most recent use” enabled?
If so, try disabling it and see if there is any difference.


#7

Thanks! Just checked and it is already disabled. Please let me know what to try next.


#8

In the screenshot provided, that option shows as enabled.

Confirming, there is no difference when this is enabled or disabled?