After ios update iPad, iPencil doest work properly in photoshop



I updated the iOS of my iPad to the latest version (11.0.3).
Everything worked fine before. But suddenly if i use Photoshop (cs6), the iPencil doesn’t work properly anymore. For example if i select the brush in the toolbar. 1 click is now a click hold. And instead of using the selected brush tool, the function stays on eyedropper tool while the brush is selected. And so every function i want to click acts wrong. The iPencil does respond but select the wrong tools and functions. If i use normal mouse on my macbook everything works works normal. So there is something wrong between the connection of my iPencil / iPad / astropad.

I use the latest updates from astropad as well. Before the iOS update everything worked fine.

Can somebody help me solve this issue.




Hi Levi,

Are you using Astropad Studio or Astropad Standard?
What Mac OS is in use? And are you using any international keyboard?

Is there any wacom drivers installed on your Mac? If so, do you know what version number?


I am having same problem. I am using standard astropad. I have as Sierra 10.12.5.
And the latest photoshop.

This just started happening to me as well. Worked fine b4.


What iOS is running in your iPad?
Is there anything that shows on screen when you try drawing?