Adonit in v2.1.3 (2036) [Fixed]


Hello guys!

Today when I restarted my Mac, I saw that Astropad was updated (there was a previous release in the trash and it was erased).
When I tried to use my Adonit Pixel with Photoshop it worked like garbage, doesn’t recognize brush strokes, and had to touch repeatdly to recognize one single touch.
Using finger works normally.
I restarted both iPad and Mac software, but no changes.
Any ideas about this problem?

The current Astropad version installed is 2.1.3 (2036)
My setup is Mac mini 2014 running macOS Sierra 10.12.3
iPad air running iOS 10.2.1


Does your Adonit work fine in Procreate or any other iPad software that support the stylus?

So far we have not heard that the new update causes any issue like this.


It works perfectly with Procreate. Actually, the problem is only with the Astropad latest update.
I tried to draw in Sketchbook pro 7 and the lines worked enough to make a sketch, and then, it started to fail again. Sometimes if you keep pressing the pen, it works again while holding down. Releasing, start to fail again. The effect is similar to, when in Stylus mode, you try to touch using fingers and it only appears a fading red circle with an X.
Tried using wi-fi and cable connected… fails the same way.


I tried again a couple of times and apparently it worked again after that.
Might be memory issues? Maybe the iPad… it’s the Air 1.
The Mac is 8GB and no apps running beyond Photoshop and Astropad. My artwork is not so complicated, in general, A4 size 300 dpi.


Interesting. Perhaps something in the bluetooth stack was messed up.
We have seen that happen with Adonit styluses.
If it happens again, restarting your iPad is usually a good way to solve it


Ok. If it happens again, I’ll try it.
Thanks for the support Giovanni!